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Materials 

Reagents 

• Schneider’s Drosophila medium (Life technologies cat. no. 21720-001) 

• Insulin, 10mg/ml (Sigma cat. no. I1882-100MG) 

• Fetal Bovine Serum (Life technologies cat. no. 10437-028) 

• Halocarbon oil 27 (Sigma cat. no. H8773) 

• Immersion medium Immersol W 2010 (Carl Zeiss cat. no. 444969-0000-000) 

 

Equipment 

• Dissecting microscope 

• 2-well concavity slide (VWR cat. no. 100491-032) 

• Lumox dish 50mm (Sarstedt cat. no. 94.6077.410) 

• Zeiss LSM 710 microscope 

• Fine Tip Transfer Pipets (Thermo Scientific cat. no. 1371125) 

• Dumont #5 forceps (Fine Science Tools cat. no. 11251-30) 

• Fisher brand no. 1 coverslips, size: 22x22mm (Fisher, cat. no. 12-542-B) 

• Fisher brand no. 1 coverslips, size: 40x22mm (Fisher, cat. no. 12-545C) 

 

 

Procedure 
Preparations before live imaging 

1) Select young female EcadTS and EcadTS-C flies that are 3-4 days old. Keep them on 

plain fly food before fattening.  

? Troubleshooting 

 

2) Right before imaging, fatten flies with fresh yeast for 16-18 hours at 25 °C. Yeast 

granules after absorbing moisture cover about 1/3 of the surface of fly food. 

 

3) On the day of imaging, prepare a new or unscratched Lumox dish.  

 

4) Take out an aliquot of insulin solution (10μl for 500μl imaging medium) from -80°C 

fridge to let it thaw at room temperature.  



 

5) Mix thawed insulin with Schneider’s Drosophila medium supplemented with 20% 

Fetal Bovine Serum to make complete live imaging medium. 

CRITICAL STEP: For dissection and FRET imaging, always use fresh live imaging 

medium (less than 20 days old).  

CRITICAL STEP: We found that the correct range of pH (6.85-6.95) is important for 

border cell to be healthy and migrate well (average speed is about or more than 

0.6µm/min). 

 

3. Dissect fly ovary and isolate stage 9 egg chambers 

6) Immediately before imaging, dissect around five fattened female flies to isolate fly 

ovaries and subsequently stage 9 egg chambers according to protocols established before 

(1, 2).  

CRITICAL STEP: Well-fattened ovaries should show a nice distribution of early and late 

stage egg chambers in the ovariole. Don’t use your flies for imaging if the ovaries look 

sick or under-fattened (Figure 1).  

? Troubleshooting 

 

 
Figure 1. Images of under-fattened (left) and well-fattened (right) ovaries (From Eanes Lab).  

 

7) After dissection, remove as many mature egg chambers as possible since they easily 

deplete nutrients in the medium during imaging.  

 

8) Use a fine tip transfer pipette to transfer egg chambers for imaging to a small 

Eppendorf tube.  

 

9) Wash once with 300µl complete live imaging medium. 

 

 

Prepare imaging cassette for confocal imaging: 

10) Carefully break one 22x22mm coverslip in the middle to two equal parts (11x22mm) 

using the shaft region of forceps. Wipe off fragments on the coverslip using Kim wipe. 

 

11) Apply 5μl live imaging medium onto two separate spots on the dish (5μl x 2) 

 



12) Use forceps to carefully transfer two 11x22mm coverslips to the Lumox dish 

membrane, onto the pre-applied medium droplets, with the smooth side of the coverslips 

facing inward 

 

13) Use a plastic pipette tip to carefully arrange the coverslips so that they are about 

18mm apart, and parallel to each other  

 

14) Transfer sample in 90μl live imaging medium to the center of two coverslips 

 

15) Gently cover the sample using a 22x40mm coverslip. Bubbles should be avoided in 

medium. 

CRITICAL STEP: when you slightly tilt the Lumox dish the egg chambers should be just 

barely able to move. If they move too quickly then there’s too much medium: egg 

chambers would shift during imaging. If they are unable to move then there’s insufficient 

medium: egg chambers may deform due to squeezing during imaging. 

 

16) Apply small droplets of halocarbon oil 27 to the rims of coverslip and let them spread 

and cover all the sides to prevent evaporation. 15μl of halocarbon oil in total is sufficient. 

 

 

Image acquisition 
17) On a Zeiss LSM 710 upright microscope, mount the Lumox dish with sample onto 

the motorized stage.  

? Troubleshooting 

 

18) Apply a drop of water immersion medium to the coverslip, and lower the 40x/1.1W 

LD C-Apo water objective to touch the immersion medium. 

? Troubleshooting 

 

19) Under “Locate” tab in Zen software, turn the system online.  

 

20) Switch to GFP filter. Use microscope eyepiece to adjust focal plane and locate the 

egg chambers for imaging.  

CRITICAL STEP: In order to reduce photobleaching, do not expose samples in epi-

fluorescence for too long. And do not let the objective touch the side of the Lumox dish. 

This will shift focus and possibly damage the sample. 

 

21) Switch to “acquisition” tab in Zen software. Set up three imaging tracks. Track #1 

uses a 458nm Argon laser for excitation, and acquires mTFP and FRET images 

simultaneously using channel 1 (463-501nm) and channel 2 (519-566nm). We use 100% 

laser power, and adjust pinhole size to 3 Airy Units. Use MBS 458/514 for main beam 

splitter. Track #2 utilizes a 514nm Argon laser for excitation, and acquires Venus image 

using channel 2 (519-566nm). Track #3 uses DPSS 561nm laser for excitation of Lifeact-

mRFP channel, and uses channel 3 (567-700nm) to acquire image. Channel gains are no 

more than 800 to reduce background noise. Switch tracks every frame.  

 



22) Adjust frame size to 512x512 pixels. Set averaging to 8 times for maximum signal to 

noise ratio. Use maximum speed. 

 

23) Every time when setting changes (laser power change etc.), calibrate the signal 

crosstalk and bleed-through using Cad-mTFP and Cad-Venus only sample (steps 24-25).  

 

24) Image Cad-mTFP sample using Track #1 to calculate mTFP to Venus bleed-through 

parameter. Then make a selection box on the border cells to measure the intensities of the 

selections in channel 1 and channel 2. Calculate bleed-through parameter by dividing 

intensity in channel 2 by that in channel 1 (usually around 25%-30%).  

 

25) Image Cad-Venus sample using Track #1 and Track #2 to calculate the excitation of 

Venus by mTFP laser. Then calculate ratio of channel 2 signals in #2 to #1. This usually 

is 5% in our case and is ignored.  

Notes: Because mTFP cannot be excited at Venus excitation wavelength and the Venus 

bleed-through into mTFP channel is weak, these two calibrations are not carried out. All 

the acquisition parameters should be the same with Cad-mTFP and Cad-Venus only 

controls. 

 

26) Select all stage 9 border cells as early as those just detached from the anterior end of 

the egg chamber, and as late as those that have reached midpoint of migration path.  

CRITICAL STEP: Only select fully detached border cell cluster for image acquisition. 

We consider cluster as detached if it only has a thin strip connecting with anterior end as 

shown in the RFP channel (Fig. 2C) or totally unconnected (not shown). 

 

 
Figure 2. Examples of undetached (A) and detached (B-C) border cell clusters. (A-B) Venus 

channel in FRET acquisition. (C) Lifeact-mRFP channel in same cluster as (B). 

 

27) E-cadherin tension sensor should express well and localize nicely to cell boundaries 

(Figure 3A). Do not use your sample for imaging if membrane localization is not clear 

(Figure 3B). Lifeact-mRFP should also express well in every border cell. Avoid egg 

chambers that look damaged with broken follicle cells. 
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Figure 3. Examples of clear (A) and unclear (B) membrane localization 

? Troubleshooting 

 

28) Under “Live”, adjust focus so that border cell mid-plane is in focus. 

 

29) Under 2x magnification, rotate crop box so that it is parallel to the migrating border 

cell cluster, with the front protrusion facing right side of the box. 

 

30) Acquire the image using Tracks #1, 2, & 3. 

 

Image analysis 
Remove image background 

31) Open the mTFP, Venus, and FRET images in ImageJ software.  

 

32) Measure background using a rectangular selection box around 20µm in height and 

width. Avoid selecting sample region.  

? Troubleshooting 

 

33) Use “Analyze->Histogram” to get the background mean and standard deviation.  

 
34) Calculate background value as “mean+3x StdDev”.  

Select the entire image. Subtract background value using “Process->Math->Subtract” 

function.  

(CRITICAL STEP: do not use the “Process->Subtract Background” function as it uses a 

rolling ball algorithm. This function subtracts a highly non-uniform background and can 

cause potential problems.) 

 

Remove channel crosstalk and bleed through 

Select the mTFP image, multiply it by the previously calculated mTFP to Venus channel 

bleed-through factor (~25%-30%) using “Process->Math->Multiply” function to get 

mTFP-to-FRET image. 



 
Use the Venus image, multiply it with the factor of Venus excited by mTFP excitation 

light using the same function to get Venus-to-FRET image. This is negligible so we don’t 

include it in our calculations 

 

Subtract the mTFP-to-FRET image from the FRET image using “Process->Image 

Calculator” function and generate the pure FRET image FRET-pure. Select the “Create 

new” window option otherwise the original image will be lost. 

 
 

Apply “Process->Smooth” on mTFP and FRET-pure images.  

 

Register FRET and mTFP images (optional) 

Shifts between different channels can be significant in epi-fluorescence microscope 

because different filter may not align perfectly in the light path. For confocal imaging, 

this problem is usually less severe. However, using image registration can still reduce 

artifacts, especially near the edge of the structures.  

Here one can use a third party plug-in called TurboReg. 

Usually, because the channel shifts will not deform the image, we choose “rigid body”. 

Usually we register the mTFP channel to the FRET-pure channel to generate a registered 

mTFP, mTFP-reg.  



 
 

Generation of Mask 

Duplicate the FRET-pure channel using Image->Duplicate function to create FRET-pur2.  

Use Image->adjust->threshold to create binary mask. Image. Choose Dark background to 

select the bright signal.  Use the default algorithm.  

 
 

For convenience, the generated mask should be divided by 255 to create a 0/1 binary 

image, mask01. (Use “Process->Math->Divide” function) 

 

Generate FRET image and display 

First, multiply the mask01 with FRET-pur channel using “Process->Image Calculator” to 

get a new image “FRET-masked”.  



 
Then divide the “FRET-masked” with “mTFP-reg” to get the final FRET image using 

same Image Calculator. Choose 32-bit float option this time.  

 

FRET index distribution can be seen from Image->Adjust->Brightness/Contrast or from 

Analysis->Histogram.  

  
By changing the lookup-table using Image->Lookup Tables (or Plugins->LUT), one can 

visualize the dynamic range using different color coding, like rainbow RGB, Red-hot etc. 

Using the same Image->Adjust->Brightness/Contrast tool, one can choose the optimal 

range of display to best capture the dynamic range of the probe (this will not change the 

actual value of each pixel).  

 

Color ramp can be added by Plugins->LUT->Add Ramp function.  

 

Save the 32-bit image in tiff format. 

 



Convert FRET image to RGB image for display purposes. 

 

 

Selection of front and back of the cluster for FRET comparison 

Make a 7um x 7um ROI selection box (can be saved at Analyze -> tools -> ROI 

manager). If there is a front protrusion, make a selection so that the tip of the protrusion 

just touches the right boundary of the box; if there is a back protrusion, tip of the 

protrusion should touch the left boundary of the box 

 

 

 

 

 

 

 

 

 

 
Figure 4. Selection of front and back protrusions 

 

If the protrusion doesn’t have clear RFP signal, could only be visualized after manually 

increase intensity, and is discontinuous with the main cluster, the protrusion is probably 

not in focus when you acquire the image. FRET index will only indicate nurse cell-nurse 

cell boundary tension. Discard such images or focus better when acquiring image. 

 

 

 

 

 

 

 

 

 

 

 
Figure 5. RFP channel showing image before (A) and after (B) manual increase of intensity. 

Arrow: position of front protrusion. 

 

In some cases, the front protrusion has strong Lifeact-mRFP signal, but weak to non-

existent tension sensor or control signal (Figure 6). This is probably due to the fast 

formation of front protrusions. We exclude such samples.  

 

Back protrusion:  

Left boundary of box 

Front protrusion:  

Right boundary of box 

A B 



 
Figure 6. Absence of tension sensor signal in the front protrusion in mTFP (A) and Venus (B) 

channels while Lifeact-RFP signal (C) is present. Arrows: tip of front protrusion. 

 

If the front protrusion in RFP channel doesn’t co-localize with any tension sensor signal 

(Fig. 7C small arrow), select the region on border cell cluster most adjacent to the 

protrusion (Fig. 7A. big arrow). 

 
Figure 7. Selection of region closest to unclear protrusion. 

 

If there are multiple front protrusions, choose one whose tip extends most posteriorly. 

Similarly if there are multiple back protrusions, choose one whose tip extends most 

anteriorly. The protrusion chosen should be in focus. 

 

If there is no protrusion (Figure 6A, box 1), or protrusion is short (Figure 6A, box 2), 

adjust the width of the box so that you only select the border cell-nurse cell boundary 

membrane, the outer-most point of the membrane touches boundary of the box (Figure 

6A, box 1) and avoid aggregates (Figure 6A, box 2). 

 

 

 

 

 

 

 

 

 

 

 
Figure 6. Narrower selection boxes that restrict selection to border cell membrane and avoid 

internal aggregates (circled regions). 

A B C 

1 

2 

A B C 

A B C 



 

Due to the properties of mTFP, it tends to form aggregates inside the cluster. Aggregates 

are usually inside the border cell, below the membrane. They should be round and bright 

in mTFP channel (circled in Figure 6B). We will avoid those aggregates (i.e. Figure 6B 

oval selection 2) when measuring membrane FRET. Sometimes it is uncertain what are 

aggregates and what are real membrane signal. Go to the final FRET image (Figure 6C). 

The circled aggregate regions show clear and abrupt drop in FRET index compared to 

adjacent membrane and should be avoided.  

 

Only select regions that are located on the membrane 

Solution: do selection on the final FRET image and use RFP image as reference. 

 

(YA’s selection on overlay of mTFP and RFP image:            (DC’s selection on FRET  

hard to avoid internal “aggregate” region)                            image: membrane-localized) 

 
Figure 7. Selection is better done on the final FRET image. 

 

 

 

 



 
 

 

 

 

Trouble shooting table 
Step Problem Possible reason Solution (s) 
1 Flies appear under 

fattened 

Not enough time were given 

for fattening, or flies are too 

young to begin with 

Fatten 3-4 day old female 

flies for 16-18 hours. 

6 In imaging, follicle cell 

layer looks broken 

Egg chambers were possibly 

touched by forceps during 

dissection 

Avoid touching egg 

chambers, especially stage 9 

ones. 

17 Marked position change 

z-focus dramatically 

after returning to it from 

other positions 

Lumox dish didn’t fit 

perfectly to the stage. 

After mounting dish onto 

the holder, turn slightly in 

both directions to make sure 

dish is level. 

18 Water evaporates during 

imaging 

Image for too long Use Immersion medium 

Immersol W 2010 by Zeiss 

instead. 

27 UAS-Lifeact-mRFP is 

not expressed well in 

every border cell 

Flies are fattened below 25°C Make sure flies are fattened 

at least at 25°C to allow 

optimum Gal4/UAS 

expression 

32 Image after background 

subtraction was too dim 

Background was selected at 

sample region 

Adjust contrast to increase 

visibility of dim samples so 

they could be avoided 
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